I have downloaded Bootstrap and jquery min then set up a web page and tested it on my Xaamp server. The css seems to be working but I can't get any responses when testing button clicks, dropdowns etc. Nothing happens. I have looked over everything very carefully and I am sure it must be something simple I have missed. Please can anyone suggest what the problem might be. Thank you.

<!DOCTYPE html>
<html lang="en">
<head>
<meta charset="utf-8">
<meta http-equiv="X-UA-Compatible" content="IE=edge">
<meta name="viewport" content="width=device-width, initial-scale=1">
<!-- The above 3 meta tags *must* come first in the head; any other head content must come *after* these tags -->
<title>Jolly Good Productions</title>

<!-- Bootstrap -->
<link href="css/bootstrap.min.css" rel="stylesheet">

<!-- HTML5 shim and Respond.js for IE8 support of HTML5 elements and media queries -->
<!-- WARNING: Respond.js doesn't work if you view the page via file:// -->
<!--[if lt IE 9]>
<script src="https://oss.maxcdn.com/html5shiv/3.7.2/html5shiv.min.js"></script>
<script src="https://oss.maxcdn.com/respond/1.4.2/respond.min.js"></script>
<![endif]-->
</head>
<body>

<h1>Hello, world!</h1>
<button type="button" class="btn btn-success" onclick="$(this).hide();">Click me!</button>

<!-- jQuery (necessary for Bootstrap's JavaScript plugins) -->
<script src="js/jquery.min.js"></script>
<!-- Include all compiled plugins (below), or include individual files as needed -->
<script src="js/bootstrap.min.js"></script>

</body>
</html>

ps: I can get normal javascript commands to work using simple functions written on the page.