Results 1 to 2 of 2

Thread: bootstrap https and drupal

  1. #1
    Junior Member
    Join Date
    Mar 2014
    Posts
    2

    bootstrap https and drupal

    Hi

    I have a drupal 7 site that has bootstrap incorporated, However i am having problems with my https pages as they are only partially encrypted as The page was 'loaded over HTTPS, but ran insecure content from 'http://netdna.bootstrapcdn.com/twitter-bootstrap/2.3.1/js/bootstrap.min.js': this content should also be loaded over HTTPS.'

    ive looked on drupal forums and one person suggested modifying a template.php file and replacing 'http://netdna.bootstrapcdn with 'https://netdna.bootstrapcdn . ive made the change however looking at web page page source both http and https references appear . ive even removed eveything from the template.php and still the http reference appears.

    consequently my page/s remain partially encrypted

    I wonder if anyone can shed any light on this problem - if anyone knows drupal or can give an educated guess - and possibly point to where the http reference is coming from

    thanks in advance

    *********

    update 19/3/14 23:07

    I have found the solution i think
    in drupal you have themes . I am using oa_radix . within each theme there is a template.php and within that file is a line DRUPAL_ADD 'http://netdna.bootstrapcdn with 'https://netdna.bootstrapcdn i changed this to https as instructed but nothing changed. As i said both http and https references still appeared in web page page source. scratching my head and looking through the files theres another theme called radix which im not using . so in my mind this should not affect anything . however changing radix template.php ( which i dont use ) to match oa_radix ( which i do use ) seems to have solved the problem !
    Last edited by geej; 03-19-2014 at 11:07 PM.

  2. #2
    Junior Member
    Join Date
    Mar 2014
    Posts
    2
    I have found the solution i think
    in drupal you have themes . I am using oa_radix . within each theme there is a template.php and within that file is a line DRUPAL_ADD 'http://netdna.bootstrapcdn with 'https://netdna.bootstrapcdn i changed this to https as instructed but nothing changed. As i said both http and https references still appeared in web page page source. scratching my head and looking through the files theres another theme called radix which im not using . so in my mind this should not affect anything . however changing radix template.php ( which i dont use ) to match oa_radix ( which i do use ) seems to have solved the problem !

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •